aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-bottle-servefiles/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-05 15:15:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:14 +0000
commit1c5a64b1877d5f6f067258f962d7ca1c7871ecfe (patch)
treec29bbc3ef764e992d1478249a5acdfa6cfaab0e9 /testing/py-bottle-servefiles/APKBUILD
parentb80e6524f2445681e5c5a1868bbce1f4eb0fb150 (diff)
testing/py-bottle-servefiles: new aport
Bottle plugin for serving files https://bitbucket.org/rudylattae/bottle-servefiles
Diffstat (limited to 'testing/py-bottle-servefiles/APKBUILD')
-rw-r--r--testing/py-bottle-servefiles/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-bottle-servefiles/APKBUILD b/testing/py-bottle-servefiles/APKBUILD
new file mode 100644
index 00000000000..bd9b177338f
--- /dev/null
+++ b/testing/py-bottle-servefiles/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-servefiles
+_pkgname=bottle-servefiles
+pkgver=0.1.2
+pkgrel=0.dev
+pkgdesc="Bottle plugin for serving files"
+url="https://bitbucket.org/rudylattae/bottle-servefiles"
+arch="noarch"
+license="BSD"
+depends="python py-bottle"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-${pkgver}dev.zip"
+
+_builddir="$srcdir"/$_pkgname-${pkgver}dev
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="7f0f2e2df7cd99858d58abefb26eb6a3 bottle-servefiles-0.1.2dev.zip"
+sha256sums="163f182a224c6b4bce47284948d8d7d747662d9da63becf76b4a543f824a2ca0 bottle-servefiles-0.1.2dev.zip"
+sha512sums="9a5976abf3e562c8d77b0e4805ba62bbf9ae0796c2af661b1715415fca4a5680beb8bdea80a8600bba0aa891f0a2a94b8e72b5358a91ca58a53399525de25477 bottle-servefiles-0.1.2dev.zip"