summaryrefslogtreecommitdiffstats
path: root/testing/py-bottle-sqlite
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2015-04-16 16:15:24 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2015-05-09 07:40:25 +0000
commit6ab6d4715a3532d75cda29865a96607f67adef5e (patch)
tree81db63a2164ad192f4b8294953966e250b10309a /testing/py-bottle-sqlite
parent0b0d9a059131071d24542c54c812d595cc72f492 (diff)
testing/py-bottle-sqlite: new aport
SQLite3 integration for Bottle https://pypi.python.org/pypi/bottle-sqlite/
Diffstat (limited to 'testing/py-bottle-sqlite')
-rw-r--r--testing/py-bottle-sqlite/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-bottle-sqlite/APKBUILD b/testing/py-bottle-sqlite/APKBUILD
new file mode 100644
index 00000000000..801068a1ba7
--- /dev/null
+++ b/testing/py-bottle-sqlite/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-sqlite
+_pkgname=bottle-sqlite
+pkgver=0.1.2
+pkgrel=0
+pkgdesc="Bottle sqlite plugin"
+url="https://pypi.python.org/pypi/bottle-sqlite"
+arch="noarch"
+license="MIT"
+depends="python py-bottle"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="802f6b9ea861e53e26e0bfa256925d45 bottle-sqlite-0.1.2.tar.gz"
+sha256sums="3106d332270022dcec66102082906da47bcc62acd43a44c3deea9b398ef3eeab bottle-sqlite-0.1.2.tar.gz"
+sha512sums="6314f80e76cfe6f592f244708501d6e922b2cf4c50ea04d21eccbad7fc903c0ae607e3f2b446fd3f1066eebc043be24c81ef9724008b10a513fde06f2864a3f0 bottle-sqlite-0.1.2.tar.gz"