summaryrefslogtreecommitdiffstats
path: root/testing/py-centinel/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-08-21 22:05:43 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2014-08-23 10:29:10 +0000
commitfb4bf6c38facef0875752269bfbc2f147d35a315 (patch)
treeca4eade7273618c51edf79cf56780a5a04452fef /testing/py-centinel/APKBUILD
parentd358ca9f258d63780ea616ef1642b75ffe740f00 (diff)
testing/py-centinel: new aport
Centinel is a tool used to detect network interference and internet censorship. https://github.com/projectbismark/centinel
Diffstat (limited to 'testing/py-centinel/APKBUILD')
-rw-r--r--testing/py-centinel/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-centinel/APKBUILD b/testing/py-centinel/APKBUILD
new file mode 100644
index 00000000000..bf732489c8b
--- /dev/null
+++ b/testing/py-centinel/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-centinel
+_pkgname=centinel
+pkgver=0.1.3
+pkgrel=0
+pkgdesc="A tool used to detect network interference and internet censorship"
+url="https://github.com/projectbismark/centinel"
+arch="noarch"
+license="MIT"
+depends="python py-dnspython"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="51dc7adedc5063c341a42b16ffb73d50 centinel-0.1.3.tar.gz"
+sha256sums="6cebe17a0864e0576b3eb207f29b0c72962563b29b408a5c36a75d4e7f861096 centinel-0.1.3.tar.gz"
+sha512sums="d20a4077bb416af653d8fd02b18dcb2060637d431013c26a2b3941504b01f733e259c5bcc0dec016687fea0cbc617542a7363d42c40230c0a904d16dde31e1a5 centinel-0.1.3.tar.gz"