aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-cherrypy
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-04 22:11:33 +0000
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-09-08 14:34:30 +0200
commit5a5238bba0047be197d78d55f206a3d8e552b7b8 (patch)
tree40107c653d2262894661f5bfde0c0745b8caea4a /testing/py-cherrypy
parentf8149cbe4b7cc65fc32951b4adeffcd09245a6d5 (diff)
testing/py-cherrypy: update APKBUILD layout
Diffstat (limited to 'testing/py-cherrypy')
-rw-r--r--testing/py-cherrypy/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/testing/py-cherrypy/APKBUILD b/testing/py-cherrypy/APKBUILD
index b974cb07d3c..257ae373add 100644
--- a/testing/py-cherrypy/APKBUILD
+++ b/testing/py-cherrypy/APKBUILD
@@ -17,10 +17,18 @@ source="http://download.cherrypy.org/cherrypy/$pkgver/$_pkgname-$pkgver.tar.gz"
# The real source is the following:
#http://download.cherrypy.org/cherrypy/$pkgver/$_pkgname-$pkgver.tar.gz"
#but seems not available atm
+
_builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
package() {
cd "$_builddir"
python setup.py install --root=$pkgdir
install -Dm644 cherrypy/LICENSE.txt ${pkgdir}/usr/share/licenses/custom/${pkgname}/license
}
md5sums="c1b1e9577f65f9bb88bfd1b15b93b911 CherryPy-3.2.2.tar.gz"
+sha256sums="dc5a88562795c2ee462dac5b37aba1cf4f34f3e27281ec11049227039308b691 CherryPy-3.2.2.tar.gz"
+sha512sums="89cebf63d48df5bec880bcbc13b3e2ae6da76f59c06803177cc8d6905e2d4444de7bb9a63189e3d6a3fd82e2a2464f419cfa74c60b2765e9ef89866847d55b7e CherryPy-3.2.2.tar.gz"