aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-constantly/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-07-26 15:37:20 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-31 06:14:41 +0000
commitb36cbb46378e56082dc1b60ad58699b6899112d1 (patch)
tree89dc3be5e49c2b16a7ff1d796defc6fdce3ccb9c /testing/py-constantly/APKBUILD
parenta2659b2ed15b531f53c6369dbacee11616fd759f (diff)
testing/py-constantly: new aport
Diffstat (limited to 'testing/py-constantly/APKBUILD')
-rw-r--r--testing/py-constantly/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/py-constantly/APKBUILD b/testing/py-constantly/APKBUILD
new file mode 100644
index 00000000000..2edf842917b
--- /dev/null
+++ b/testing/py-constantly/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: prspkt <prspkt@protonmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py-constantly
+_pkgname=constantly
+pkgver=15.1.0
+pkgrel=0
+pkgdesc="Library that provides symbolic constant support"
+url="https://github.com/twisted/constantly"
+arch="noarch"
+license="MIT"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="ccc6f41b0bd552d2bb5346cc9d64cd7b91a59dd30e0cf66b01e82f7e0e079c01c34bc6c66b69c5fee9d2eed35ae5455258d309e66278d708d5f576ddf2e00ac3 constantly-15.1.0.tar.gz"