aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-diskcache
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 02:25:42 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 02:25:42 +0000
commit1084946dd3d7f63fceb8ecd4beb843f3447f8593 (patch)
tree4bc4fc626b2a52734847cf8c55fd08e9928d2775 /testing/py-diskcache
parent9b2481fbfe666cb5361ab0a46848a39d15419cfa (diff)
testing/py-diskcache: new aport
Diffstat (limited to 'testing/py-diskcache')
-rw-r--r--testing/py-diskcache/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/py-diskcache/APKBUILD b/testing/py-diskcache/APKBUILD
new file mode 100644
index 00000000000..592765919e4
--- /dev/null
+++ b/testing/py-diskcache/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-diskcache
+pkgver=2.8.3
+pkgrel=0
+pkgdesc="disk caching implementation"
+url="http://pypi.python.org/pypi/diskcache/"
+arch="noarch"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-diskcache:py2 py3-diskcache:py3"
+source="https://files.pythonhosted.org/packages/source/d/diskcache/diskcache-$pkgver.tar.gz"
+
+builddir="$srcdir"/diskcache-$pkgver
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"
+ _py python2
+}
+
+py3() {
+ cd "$builddir"
+ _py python3
+}
+
+sha512sums="d96ac76dfb68cb817febd3f4ed8927a8409c02b13b4112a739528cade40f9a588c732dfc3148392dd12676380c3a2b006ee63b86f30ad70f5d205273003bf23d diskcache-2.8.3.tar.gz"