aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-dtopt/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-28 16:31:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-30 08:23:14 +0000
commit73549928578654beb0ce6b1fd5a22b174b63a63f (patch)
treea891d1e2ecd8f8bce7bee456769ebd604443cb55 /testing/py-dtopt/APKBUILD
parent533205212842f2c6c5ea5f7cd6ab43006d0f6a12 (diff)
testing/py-dtopt: new aport
Additional options to doctest examples http://pypi.python.org/pypi/dtopt/
Diffstat (limited to 'testing/py-dtopt/APKBUILD')
-rw-r--r--testing/py-dtopt/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-dtopt/APKBUILD b/testing/py-dtopt/APKBUILD
new file mode 100644
index 00000000000..4722f303382
--- /dev/null
+++ b/testing/py-dtopt/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-dtopt
+_pkgname=dtopt
+pkgver=0.1
+pkgrel=0
+pkgdesc="Additional options to doctest examples"
+url="http://pypi.python.org/pypi/dtopt/"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="9a41317149e926fcc408086aedee6bab dtopt-0.1.tar.gz"
+sha256sums="06ae07a12294a7ba708abaa63f838017d1a2faf6147a1e7a14ca4fa28f86da7f dtopt-0.1.tar.gz"
+sha512sums="de835eb5c8ba25939bb989f53d1fd85d738ea15ed1fd787d76b2d34aeb141a06186b1db74b31dfe5d7fd70640ec253f6f2b29bff46280ef2527551e6a860095d dtopt-0.1.tar.gz"