aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-dulwich
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-03-01 23:13:17 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-17 13:37:06 +0000
commite87132aaa331ac8ac7bac094cccb4863ddbed588 (patch)
treee1073a8b1523154abda70d00bf1811d5cf45e09e /testing/py-dulwich
parent77e94a85b8d174b67f8e400212d78c8c48a9f8a4 (diff)
testing/py-dulwich: new aport
A python implementation of the Git file formats and protocols http://www.samba.org/~jelmer/dulwich/
Diffstat (limited to 'testing/py-dulwich')
-rw-r--r--testing/py-dulwich/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py-dulwich/APKBUILD b/testing/py-dulwich/APKBUILD
new file mode 100644
index 00000000000..3a9168c826a
--- /dev/null
+++ b/testing/py-dulwich/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-dulwich
+_pkgname=dulwich
+pkgver=0.8.3
+pkgrel=0
+pkgdesc="A python implementation of the Git file formats and protocols"
+url="http://www.samba.org/~jelmer/dulwich/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://samba.org/~jelmer/$_pkgname/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="8c38eb9c4001c56519cefb0b8acc8e6d dulwich-0.8.3.tar.gz"