aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-embedly/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-08-21 17:59:34 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2014-08-23 10:28:59 +0000
commit56cc2787bbe0bf71c4d01a5bbfe803ff8507ee96 (patch)
tree8d8069231396473a692c934432d24ab874f3c849 /testing/py-embedly/APKBUILD
parent7ff77c1df9c16f6a9850ed02ca88387747d7e2d9 (diff)
testing/py-embedly: new aport
A Python Library for Embedly https://github.com/embedly/embedly-python
Diffstat (limited to 'testing/py-embedly/APKBUILD')
-rw-r--r--testing/py-embedly/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-embedly/APKBUILD b/testing/py-embedly/APKBUILD
new file mode 100644
index 00000000000..188849f786d
--- /dev/null
+++ b/testing/py-embedly/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-embedly
+_pkgname=Embedly
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="A Python module for Embedly"
+url="https://github.com/embedly/embedly-python"
+arch="noarch"
+license="BSD"
+depends="python py-httplib2"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="67bfdf6496e219307ffbefef15748702 Embedly-0.5.0.tar.gz"
+sha256sums="e10bca4b5e25e8f30e93eb459921f787b08efc4004b6370a68f4c8984f6f16e1 Embedly-0.5.0.tar.gz"
+sha512sums="c85abacaa33b7897ccda79dc3746497f4eefe54bac3eef0aaa7c9120fec14ff6b7652a342303bea0667f60c2e31cb1591a22cddeff6827c87c6e2b1cc3274469 Embedly-0.5.0.tar.gz"