aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-evohome-client
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-04-19 13:04:12 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-04-19 13:04:16 +0200
commite9342bdb58c7ff31ccbd76ed3753778752072a2d (patch)
tree4d96544d28412a845183fab82cb6e4c3d066b564 /testing/py-evohome-client
parent397bd7cabdd3d5a57c29e9e78d1cb1fd5cfc3731 (diff)
testing/py-evohome-client: new aport
Diffstat (limited to 'testing/py-evohome-client')
-rw-r--r--testing/py-evohome-client/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py-evohome-client/APKBUILD b/testing/py-evohome-client/APKBUILD
new file mode 100644
index 00000000000..aa525a84a4c
--- /dev/null
+++ b/testing/py-evohome-client/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-evohome-client
+pkgver=0.2.5
+pkgrel=0
+pkgdesc="Python client to access the Evohome web service"
+url="https://github.com/watchforstock/evohome-client"
+arch="noarch"
+license="Apache-2.0"
+depends="python py-requests"
+depends_dev=""
+makedepends="$depends_dev py-setuptools"
+install=""
+subpackages=""
+source="evohome-client-$pkgver.tar.gz::https://github.com/watchforstock/evohome-client/archive/$pkgver.tar.gz"
+
+builddir="$srcdir"/evohome-client-$pkgver
+
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="71ae416b948b367f8d0663851c976a2f evohome-client-0.2.5.tar.gz"
+sha256sums="55abbb9d2e68fb06893f9dcc39ed5721cbeae15552bbcf47122bcfb564512b71 evohome-client-0.2.5.tar.gz"
+sha512sums="d475906168371e09f81d955574a070e9225844f99309d3d9875d5adccfc383795680d784400841617f49b0c43aa0d02fc2555649ded2adfa0beeccfa38d60874 evohome-client-0.2.5.tar.gz"