aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-geoip/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-30 11:08:17 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-09-30 11:08:17 +0000
commitfa4763b7bbe10744c40cfd8b34b9f92a0fe89d8a (patch)
tree7c88301d14356f4acb2d2bdd4b612a545199963f /testing/py-geoip/APKBUILD
parent3cba2643009a9a2e1ce065e4d0bbfbb1ed48a720 (diff)
testing/py-geoip: new aport
A Pure Python GeoIP API https://github.com/appliedsec/pygeoip
Diffstat (limited to 'testing/py-geoip/APKBUILD')
-rw-r--r--testing/py-geoip/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-geoip/APKBUILD b/testing/py-geoip/APKBUILD
new file mode 100644
index 00000000000..94a7a3887cc
--- /dev/null
+++ b/testing/py-geoip/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-geoip
+_pkgname=pygeoip
+pkgver=0.2.7
+pkgrel=0
+pkgdesc="A Pure Python GeoIP API"
+url="https://github.com/appliedsec/pygeoip"
+arch="noarch"
+license="LGPL3+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="f7a689257ceacfb961f124e0b8cf9741 pygeoip-0.2.7.tar.gz"
+sha256sums="7c4e7b5913bf3adfc0240bde5183e37a921ded2b44bbf29531a761b83a7427fd pygeoip-0.2.7.tar.gz"
+sha512sums="7ade745efcb824d8a0f0267297db4d69a921f2ab7a5b5ee38e07ca7eac5238251df84915f619ac9ebd7c1ac36a127835d657060c57bf868516f22e3f68943200 pygeoip-0.2.7.tar.gz"