aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-hglib/APKBUILD
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-03-28 13:38:05 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-25 11:24:08 +0000
commit625d40f0ff7f056a6e1249bfd7db1ed2a716fa94 (patch)
treeceaaabf7c928ce51152d41d672760c2ad5cb4fc7 /testing/py-hglib/APKBUILD
parent5bb70e15e5fb2e62402825ae6712d9776a3244f1 (diff)
testing/py-hglib: new aport
Diffstat (limited to 'testing/py-hglib/APKBUILD')
-rw-r--r--testing/py-hglib/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/py-hglib/APKBUILD b/testing/py-hglib/APKBUILD
new file mode 100644
index 00000000000..042c68d03df
--- /dev/null
+++ b/testing/py-hglib/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=py-hglib
+_pkgname=python-hglib
+pkgver=2.4
+pkgrel=0
+pkgdesc="A fast and convenient interface to Mercurial's command server"
+url="https://pypi.python.org/pypi/python-hglib"
+arch="noarch"
+license="MIT"
+makedepends="mercurial python2-dev py-setuptools python3-dev"
+subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+sha512sums="91fff5b5badb798aa0a5a25d8544718afe545a53d1b4f5725abbf46a07a81fbbea12e3a8b05c874b4693668e3fc57362100844d7387ed3dc6dc7b50d3a7e8c52 python-hglib-2.4.tar.gz"