aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-hotqueue
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-05 13:45:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:14 +0000
commit3d9d70528a022080b42e019725b38a629054d242 (patch)
tree090ee4b884e5ec465cc9396c0561a12d75d9db0c /testing/py-hotqueue
parentac9fe81caed70610799d18b5e049ea3eb5b26154 (diff)
testing/py-hotqueue: new aport
A Python library that allows to use Redis as a message queue http://github.com/richardhenry/hotqueue
Diffstat (limited to 'testing/py-hotqueue')
-rw-r--r--testing/py-hotqueue/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-hotqueue/APKBUILD b/testing/py-hotqueue/APKBUILD
new file mode 100644
index 00000000000..a58536e6634
--- /dev/null
+++ b/testing/py-hotqueue/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-hotqueue
+_pkgname=hotqueue
+pkgver=0.2.7
+pkgrel=0
+pkgdesc="A Python library that allows to use Redis as a message queue"
+url="http://github.com/richardhenry/hotqueue"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="13c80ac6ec08fd5fbc9bb9c1818d95b9 hotqueue-0.2.7.tar.gz"
+sha256sums="978729391b91b9a29135fbc60b532466947bc4fb2e3ea26e88ca1574a582398f hotqueue-0.2.7.tar.gz"
+sha512sums="9ff8a11b4c029544d0f842feaf423a209d464daa12852d2186c2723406659040d24c556d44c0e903aebc464b02b7cdeb05d373083aa0bcedc237e6cc5719b573 hotqueue-0.2.7.tar.gz"