aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-hotqueue
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 13:01:52 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 13:08:00 -0300
commitd6d5e740d68714523b0248c13e2ef6a6434867ab (patch)
treee9429ff6c0ae47283e07f19f1d6f4f0bac6d6a59 /testing/py-hotqueue
parent34e7dcecefda82743745a61e8f49afe8f04d094d (diff)
testing/py3-hotqueue: rename from py-hotqueue
Diffstat (limited to 'testing/py-hotqueue')
-rw-r--r--testing/py-hotqueue/APKBUILD52
1 files changed, 0 insertions, 52 deletions
diff --git a/testing/py-hotqueue/APKBUILD b/testing/py-hotqueue/APKBUILD
deleted file mode 100644
index 6766349a178..00000000000
--- a/testing/py-hotqueue/APKBUILD
+++ /dev/null
@@ -1,52 +0,0 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-hotqueue
-_pkgname=hotqueue
-pkgver=0.2.8
-pkgrel=0
-pkgdesc="A Python library that allows to use Redis as a message queue"
-options="!check" # Require running instance of redis server
-url="http://github.com/richardhenry/hotqueue"
-arch="noarch !armv7" # urllib2.HTTPError: HTTP Error 403: SSL is required
-license="MIT"
-depends="py-redis"
-makedepends="py-setuptools py3-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-builddir="$srcdir"/$_pkgname-$pkgver
-
-build() {
- python2 setup.py build
- python3 setup.py build
-}
-
-check() {
- python2 setup.py test
- python3 setup.py test
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-sha512sums="89a726aa970de5f0a3c3551e69b3efad00d6b795b59cfe219a35080be4be52b894637899cd1677572419180d8aa918a64b3d227371d2c409aa8da0e15876accf hotqueue-0.2.8.tar.gz"