aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-influxdb
diff options
context:
space:
mode:
authorOlivier Mauras <olivier@mauras.ch>2016-10-26 14:20:35 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 13:32:02 +0200
commit05be1d1a61253066f5688c6efb4081a068518b94 (patch)
tree8fde636e5e97ceb3fd6372ee6ab2d4d9f0c41a17 /testing/py-influxdb
parent303aa40958fc3158587ebb38be577668ec7b5583 (diff)
testing/py-influxdb: New aport
Diffstat (limited to 'testing/py-influxdb')
-rw-r--r--testing/py-influxdb/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/py-influxdb/APKBUILD b/testing/py-influxdb/APKBUILD
new file mode 100644
index 00000000000..600e01d2ccb
--- /dev/null
+++ b/testing/py-influxdb/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Olivier Mauras <olivier@mauras.ch>
+pkgname=py-influxdb
+_pkgname=influxdb-python
+pkgver=3.0.0
+pkgrel=0
+pkgdesc="Python bindings for InfluxDB"
+url="https://github.com/influxdata/influxdb-python"
+arch="noarch"
+license="MIT"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools libressl-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/influxdata/${_pkgname}/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python=$1
+ arch="all"
+ pkgdesc="$pkgdesc - $python"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir" || return 1
+}
+
+md5sums="e89976e6131d76d939e62c7cbeba00f6 py-influxdb-3.0.0.tar.gz"
+sha256sums="c4c1562e857b43424c300db33ee0a85349ad99bd94ef87ef1f6136aeb5985cd8 py-influxdb-3.0.0.tar.gz"
+sha512sums="ed3eff631bf7f529451ec0e2db963822e948ef168bca84d81fe8a7b8a83b3762f6f5a32b6030c5c86c4de446594097f7746796f35f1ca6b06e6fa66f0cfadb2c py-influxdb-3.0.0.tar.gz"