summaryrefslogtreecommitdiffstats
path: root/testing/py-jabberbot
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-10 12:49:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-10 12:53:29 +0000
commit8c8308e72032850673a6f99a73099b704fd3a092 (patch)
tree4a08684f455e4595ece89f306fdb5e015706cfae /testing/py-jabberbot
parent3d9a76633bf2ab6dac42b493fc5c0dbc32949c67 (diff)
testing/py-jabberbot: cleanup
- set noarch - set correct makedepends and depends - add separate build function - whitespace fix
Diffstat (limited to 'testing/py-jabberbot')
-rw-r--r--testing/py-jabberbot/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/py-jabberbot/APKBUILD b/testing/py-jabberbot/APKBUILD
index 4f1295d3989..7f614b757db 100644
--- a/testing/py-jabberbot/APKBUILD
+++ b/testing/py-jabberbot/APKBUILD
@@ -6,19 +6,23 @@ pkgver=0.10
pkgrel=0
pkgdesc="A simple Jabber Bot for Python"
url="http://pypi.python.org/pypi/jabberbot"
-arch="x86"
+arch="noarch"
license="GPLv3"
-depends="xmpppy"
-depends_dev=
-makedepends="$depends_dev"
+depends="py-xmpppy python"
+makedepends="python-dev"
install=""
subpackages=""
source="http://thpinfo.com/2007/$_pkgname/jabberbot-$pkgver.tar.gz"
_builddir=$srcdir/jabberbot-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
package() {
- cd "$_builddir"
+ cd "$_builddir"
python setup.py install --root="$pkgdir"
}