aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-jmespath
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2016-03-14 15:55:28 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-03-18 09:26:47 +0000
commit3a9e441e901e01b127a1b8d4e3c22fa0d2c0254c (patch)
tree679a27d84d4435457e9d9eee6db85b48c0fbabe7 /testing/py-jmespath
parentfad623d0435bf5bbc7ad888d6a56da5c7d7e86d7 (diff)
testing/py-jmespath: new aport
JMESPath is a query language for JSON http://jmespath.org [TT: Clarify license]
Diffstat (limited to 'testing/py-jmespath')
-rw-r--r--testing/py-jmespath/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/py-jmespath/APKBUILD b/testing/py-jmespath/APKBUILD
new file mode 100644
index 00000000000..fb18035af8f
--- /dev/null
+++ b/testing/py-jmespath/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+pkgname=py-jmespath
+_pkgname=jmespath
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="JMESPath is a query language for JSON"
+url="http://jmespath.org"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=
+makedepends="python-dev py-setuptools"
+install=
+subpackages="$pkgname-tools"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/boto/$_pkgname/archive/$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname.py-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+tools() {
+ pkgdesc="$pkgdesc (command line tools)"
+ depends="$pkgname"
+ arch="noarch"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+md5sums="0b4e773df9b74377b916cb156c2be144 jmespath-0.9.0.tar.gz"
+sha256sums="64ba1d91bafef53b730d9eb696aa4a74df3dc5b6ff728c5563069382936da860 jmespath-0.9.0.tar.gz"
+sha512sums="123c49184add3a994f4289ca79152234b6723ec4ba10a090d0823f12124925ea50ff8b16d0ea491e7a0505181216faa696442ac2fd0c9b2972c78fd1e42fd850 jmespath-0.9.0.tar.gz"