aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-mechanize/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-06-30 15:47:15 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-06-30 15:47:15 +0000
commita7792e3d801561151cfa10887ca95c86d54efd6b (patch)
tree709c8d468f23c06ff3589a857cec0de29d781a4c /testing/py-mechanize/APKBUILD
parent479bcc87e93c1e992c3e21837bd5fc932ea819f9 (diff)
testing/py-beautifulsoup py-cherrypy py-mechanize calibre py-lxml:bump pkgver
Diffstat (limited to 'testing/py-mechanize/APKBUILD')
-rw-r--r--testing/py-mechanize/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/py-mechanize/APKBUILD b/testing/py-mechanize/APKBUILD
new file mode 100644
index 00000000000..0fdad0c25bb
--- /dev/null
+++ b/testing/py-mechanize/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer:
+pkgname=py-mechanize
+_pkgname=mechanize
+pkgver=0.2.4
+pkgrel=0
+pkgdesc="Stateful programmatic web browsing in Python"
+url="http://wwwsearch.sourceforge.net/mechanize/"
+arch="noarch"
+license="BSD ZPL"
+depends=
+depends_dev="python-dev py-setuptools"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://wwwsearch.sourceforge.net/$_pkgname/src/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+package() {
+ cd "$_builddir"
+ python setup.py install --root=$pkgdir
+ install -Dm644 COPYING.txt ${pkgdir}/usr/share/licenses/custom/${pkgname}/COPYING.txt
+}
+md5sums="0c1c3cec1c6d7b5d87662a069f04eb8d mechanize-0.2.4.tar.gz"