aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-mystrom
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-19 10:18:40 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 13:07:13 +0200
commit97474935043384a90c3ece482fe991e076b71a10 (patch)
tree66230b41794e2a2123a1c73cc5e4fcf03798dba1 /testing/py-mystrom
parent930bf3243c56f3445fe89f7691be2c6173fd30b0 (diff)
testing/py-mystrom: new aport
Python API for controlling myStrom switches https://github.com/fabaff/python-mystrom
Diffstat (limited to 'testing/py-mystrom')
-rw-r--r--testing/py-mystrom/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/py-mystrom/APKBUILD b/testing/py-mystrom/APKBUILD
new file mode 100644
index 00000000000..03556521f73
--- /dev/null
+++ b/testing/py-mystrom/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-mystrom
+_pkgname=python-mystrom
+pkgver=0.3.6
+pkgrel=0
+pkgdesc="Python API for controlling myStrom switches/plugs"
+url="https://github.com/fabaff/python-mystrom"
+arch="noarch"
+license="MIT"
+depends="py-requests"
+makedepends="python2-dev py-setuptools python3-dev"
+subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+md5sums="b02039068f4c4b5c2ba29201aadbb941 python-mystrom-0.3.6.tar.gz"
+sha256sums="01b732d222779a0f39e45720d4e757143952979c5a2d71ce00ed3bf72a8ec32d python-mystrom-0.3.6.tar.gz"
+sha512sums="45f7c85d41a47e0295a7bda1f07b920cd8b89944b2bdfb4ff7da088659e345b8ad5b76eb6ac010aaad55d471b3d8c9d162101dca5be6b3366fdad85077ad06df python-mystrom-0.3.6.tar.gz"