aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-nmap
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-09 17:25:02 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 10:52:10 +0200
commitb4f8c61d329b3eb6620a4366d7609926ca52ebcb (patch)
tree8b584bd7ed5100b0d5e21c774a43143d45d126d4 /testing/py-nmap
parentd0f5c57f012d121814ed161ff54768062d1c08a0 (diff)
testing/py-nmap: new aport
A Python class to use nmap and access scan results http://xael.org/norman/python/python-nmap/
Diffstat (limited to 'testing/py-nmap')
-rw-r--r--testing/py-nmap/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/py-nmap/APKBUILD b/testing/py-nmap/APKBUILD
new file mode 100644
index 00000000000..74bc6bf713d
--- /dev/null
+++ b/testing/py-nmap/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-nmap
+_pkgname=nmap
+pkgver=0.6.1
+pkgrel=0
+pkgdesc="A Python class to use nmap and access scan results"
+url="http://xael.org/norman/python/python-nmap/"
+arch="noarch"
+license="GPL3+"
+makedepends="python2-dev py-setuptools python3-dev"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="http://xael.org/pages/python-$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/python-$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+md5sums="2795bfcbc05cbbbccfcf4df59facaab1 python-nmap-0.6.1.tar.gz"
+sha256sums="80ba0eb10a52283a54a633f40b5baa9c2ff08675d6621dd089ead942852f5bd3 python-nmap-0.6.1.tar.gz"
+sha512sums="8de9ba6d0a4cecce09e82765b8a9ac77fb4368298d5a5f9ce07b7737a90def795f1ad00885fc73ec720bea2a592230e86aaca8cacd884c9299f64ad934bcee18 python-nmap-0.6.1.tar.gz"