aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-osourcer
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-03-03 20:47:47 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-03-04 09:50:18 +0000
commit2151bae74e67503c20a1b14027253be3779ff97d (patch)
tree61b2801f38d8f1390e7762beb2de09894831bb2e /testing/py-osourcer
parent9633c066adcd4b651827d87d7a06fcb74d9ed4dd (diff)
testing/py-osourcer: new aport
osourcer is a tool to manage licenses in source code. It currently allows to add headers to javascript, css, python and HTML source files. Website: https://github.com/dnarvaez/osourcer
Diffstat (limited to 'testing/py-osourcer')
-rw-r--r--testing/py-osourcer/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-osourcer/APKBUILD b/testing/py-osourcer/APKBUILD
new file mode 100644
index 00000000000..56a8d99928f
--- /dev/null
+++ b/testing/py-osourcer/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-osourcer
+_pkgname=osourcer
+pkgver=0.1
+pkgrel=0
+pkgdesc="Tool to manage licenses in source code"
+url="http://github.com/dnarvaez/osourcer"
+arch="noarch"
+license="Apache2"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="587766a048f72838558d5b3aa351f525 osourcer-0.1.tar.gz"
+sha256sums="bf754d6c8dd4ecb5091ab2a461223b97bdf01757ece8cc1095d22c9129e8dde0 osourcer-0.1.tar.gz"
+sha512sums="20726cca90bb7b3854595b8f1e42ea4d9da25a5a07562c1ced3d08bf58d884b9aa76b8b1c5b98be1b0b50317d004c2f78f0e60c5984c2100fa503a0b660fd4dd osourcer-0.1.tar.gz"