aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pep8-naming/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-03-05 23:28:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-05 23:28:22 +0000
commitefb3c9d518b8d505148a6a0f565448a176c26d87 (patch)
tree8efa2bc46d54afc35320a8750af14c35731dcd2d /testing/py-pep8-naming/APKBUILD
parent1cded1fcdd8bed01c5e6ae0c8d7ecc2e1a7da3a6 (diff)
testing/py-pep8-naming: modernize builddir
Diffstat (limited to 'testing/py-pep8-naming/APKBUILD')
-rw-r--r--testing/py-pep8-naming/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/testing/py-pep8-naming/APKBUILD b/testing/py-pep8-naming/APKBUILD
index c3d7a22f114..104c73ad94b 100644
--- a/testing/py-pep8-naming/APKBUILD
+++ b/testing/py-pep8-naming/APKBUILD
@@ -15,16 +15,16 @@ checkdepends="py-tox py-virtualenv"
install=""
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgname-$pkgver"
+builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py build
python3 setup.py build
}
check() {
- cd "$_builddir"
+ cd "$builddir"
tox
}
@@ -49,7 +49,7 @@ _py() {
depends="$depends $python"
install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$_builddir"
+ cd "$builddir"
$python setup.py install --prefix=/usr --root="$subpkgdir"
}