aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-praw/APKBUILD
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-09-17 18:49:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-27 06:18:40 +0000
commit9784b9555bb99f9ee7ad5cc08d3c2875d3482ad4 (patch)
tree12a8022a77526331e76605aeea1e33d2ffc9ab0f /testing/py-praw/APKBUILD
parent5dc872ff2b7de65540e4f160c528d869b4485efb (diff)
testing/py-praw: add check step to run test suite
The library has a test suite, but this was never used.
Diffstat (limited to 'testing/py-praw/APKBUILD')
-rw-r--r--testing/py-praw/APKBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/testing/py-praw/APKBUILD b/testing/py-praw/APKBUILD
index e9d7569b211..ddd0e5a7a3b 100644
--- a/testing/py-praw/APKBUILD
+++ b/testing/py-praw/APKBUILD
@@ -25,6 +25,12 @@ package() {
mkdir -p "$pkgdir"
}
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ python3 setup.py test
+}
+
_py2() {
replaces="$pkgname"
depends="${depends//py-/py2-}"