aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pyautogui
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-08 09:26:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-08 09:26:47 +0000
commitdc39eb9bb7c2a36dfcd06ea852fc79408249eb6a (patch)
treefccfb3867b6b1e71f6418cfcbffff4714c9be064 /testing/py-pyautogui
parent11b2a0308520951b4e4fc17889e1631bdb355d46 (diff)
testing/py-pyautogui: upgrade to 0.9.37
use specific git commit hash in stead of just picking git master.
Diffstat (limited to 'testing/py-pyautogui')
-rw-r--r--testing/py-pyautogui/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/testing/py-pyautogui/APKBUILD b/testing/py-pyautogui/APKBUILD
index 7809e2a36e0..fa5f1e5c92c 100644
--- a/testing/py-pyautogui/APKBUILD
+++ b/testing/py-pyautogui/APKBUILD
@@ -2,8 +2,10 @@
# Maintainer: Ivan Tham <pickfire@riseup.net>
pkgname=py-pyautogui
_pkgname=PyAutoGUI
-pkgver=0.9.35
-pkgrel=2
+# upstream does not tag releases https://github.com/asweigart/pyautogui/issues/270
+_commit=61f14d7632f80267232098edd71be98a30c1339b
+pkgver=0.9.37
+pkgrel=0
pkgdesc="A cross-platform Python module for GUI automation for human beings"
url="https://pyautogui.readthedocs.io/"
arch="noarch"
@@ -11,8 +13,8 @@ license="BSD"
depends="py-xlib py-pillow"
makedepends="python2-dev python3-dev py-setuptools xvfb"
subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
-source="https://github.com/asweigart/pyautogui/archive/master.zip" # TODO: find a better source
-builddir="$srcdir/pyautogui-master"
+source="$_pkgname-$_commit.tar.gz::https://github.com/asweigart/pyautogui/archive/$_commit.tar.gz"
+builddir="$srcdir/pyautogui-$_commit"
build() {
cd "$builddir"
@@ -53,4 +55,4 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="4b8b05022708f2613241f954f0efdf5b4d6fa3d35a6e9b6901dfdf0ec9194259a449e85edb1c0eec950148c385b6eb40ef38bb27987031ec1cac83449ee50eaf master.zip"
+sha512sums="b26bee4684f9b2cb5a1ba376faceb879251dcebc7a93ef931a6b273bbebbf1c4151834035f5a52ffad1859d131d1490ad42e6b6c0a77304fd8afb316c96cde1d PyAutoGUI-61f14d7632f80267232098edd71be98a30c1339b.tar.gz"