summaryrefslogtreecommitdiffstats
path: root/testing/py-pycountry
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-06-20 12:00:47 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-06-20 12:02:01 +0000
commit9c6e16bb228787c35137e4a5576a5085a9788a10 (patch)
treefee729147f5d9c0ee9189dfad821042b129668cd /testing/py-pycountry
parent6a3353563b226569a73920d63a1ef672043b21b5 (diff)
testing/chmlib podofo py-dateutils py-importlib py-pycountry py-qt py-sip : new aports
Diffstat (limited to 'testing/py-pycountry')
-rw-r--r--testing/py-pycountry/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py-pycountry/APKBUILD b/testing/py-pycountry/APKBUILD
new file mode 100644
index 00000000000..a72eb2eb9be
--- /dev/null
+++ b/testing/py-pycountry/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer:
+pkgname=py-pycountry
+_pkgname=pycountry
+pkgver=0.12.1
+pkgrel=0
+pkgdesc="ISO country, subdivision, language, currency and script definitions and their translations"
+url="http://pypi.python.org/pypi/pycountry"
+arch="noarch"
+license="LGPL2"
+depends=
+depends_dev="python-dev py-lxml py-setuptools"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/p/${_pkgname}/${_pkgname}-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+package() {
+ cd "$_builddir"
+ python setup.py install --root=$pkgdir/ || return 1
+}
+md5sums="d593c50b446850ee40c4a342677100d5 pycountry-0.12.1.tar.gz"