aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pyramid-layout/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-29 12:27:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-30 08:23:16 +0000
commit997f028baf4e091465e0338583b36bd801ddb2bb (patch)
tree816f8fda55e2a6bbdda9020fff9ae336a7c8d08f /testing/py-pyramid-layout/APKBUILD
parent0f0d5096307b46d4f9361ada5a4c9b4ac4f2f22b (diff)
testing/py-pyramid-layout: new aport
A pyramid plugin that provides UI layout https://pypi.python.org/pypi/pyramid_layout
Diffstat (limited to 'testing/py-pyramid-layout/APKBUILD')
-rw-r--r--testing/py-pyramid-layout/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-pyramid-layout/APKBUILD b/testing/py-pyramid-layout/APKBUILD
new file mode 100644
index 00000000000..4a80e89cce5
--- /dev/null
+++ b/testing/py-pyramid-layout/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pyramid-layout
+_pkgname=pyramid_layout
+pkgver=0.8
+pkgrel=0
+pkgdesc="A pyramid plugin that provides UI layout"
+url="https://pypi.python.org/pypi/pyramid_layout"
+arch="noarch"
+license="BSD"
+depends="python py-pyramid"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="1842109124d2959bd1b01fe168456843 pyramid_layout-0.8.tar.gz"
+sha256sums="8ca58ffdd0316225e122d2f383fbea8768b44bd5af08da24db8decb72a025cfb pyramid_layout-0.8.tar.gz"
+sha512sums="9cff25311a1936e7f5dfad1af5b9a5c7e21d1fbfbe03ececee55df72dd8fbbeb24fe75992d77be41cd886d8613744ae2da10eeaaefc619cefeb867f63cd65722 pyramid_layout-0.8.tar.gz"