aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-pyrss2gen
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-07-17 07:11:25 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-18 16:54:41 +0000
commit0138a4ad5612d57990bcccd4af4a71427c9581d0 (patch)
tree2e7ecccd6f9aef9d803a090bcf6ae7a7e91f211f /testing/py-pyrss2gen
parent2e441dc9cf52fca9099212eb5bec5fce502ebe60 (diff)
testing/py-pyrss2gen: clarify license, modernize
Diffstat (limited to 'testing/py-pyrss2gen')
-rw-r--r--testing/py-pyrss2gen/APKBUILD22
1 files changed, 5 insertions, 17 deletions
diff --git a/testing/py-pyrss2gen/APKBUILD b/testing/py-pyrss2gen/APKBUILD
index 1e81c152aa0..1a818526bf5 100644
--- a/testing/py-pyrss2gen/APKBUILD
+++ b/testing/py-pyrss2gen/APKBUILD
@@ -3,32 +3,22 @@
pkgname=py-pyrss2gen
_pkgname=PyRSS2Gen
pkgver=1.1
-pkgrel=0
-pkgdesc="A generator for RSS2 using a Python data structure"
+pkgrel=1
+pkgdesc="RSS2 generator"
url="http://dalkescientific.com/Python/PyRSS2Gen.html"
arch="noarch"
-license="BSD"
+license="BSD-2-Clause"
depends=""
depends_dev=""
makedepends="py-setuptools python2-dev python3-dev"
install=""
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$_builddir"
- python2 setup.py build || return 1
+ python2 setup.py build
python3 setup.py build
}
@@ -55,6 +45,4 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-md5sums="3529f831c6a4ed717b55315974e16317 PyRSS2Gen-1.1.tar.gz"
-sha256sums="7960aed7e998d2482bf58716c316509786f596426f879b05f8d84e98b82c6ee7 PyRSS2Gen-1.1.tar.gz"
sha512sums="23079bdd6a54c0c5f27f0ade81b8ac1a28031779b9952e2d2f16d5100fa0f58c1f6b0a3f02a5e2c7d2d0e309c369a5f518ebcafb77f17c3d2f639b997d13fbd4 PyRSS2Gen-1.1.tar.gz"