summaryrefslogtreecommitdiffstats
path: root/testing/py-scipy
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-03-28 21:21:37 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-10 11:21:39 +0000
commit010383655bca6299eb50d1b59d82749dfc5c49d8 (patch)
tree0050f0fb02137397caca8274d94eb42a980cff13 /testing/py-scipy
parent955a74ce66ee1c37e5b7c2b2860f0bd6cd22e202 (diff)
testing/py-scipy: upgrade to 0.19.0 and modernize abuild
Diffstat (limited to 'testing/py-scipy')
-rw-r--r--testing/py-scipy/APKBUILD26
1 files changed, 7 insertions, 19 deletions
diff --git a/testing/py-scipy/APKBUILD b/testing/py-scipy/APKBUILD
index d184eac47e4..242ecb48075 100644
--- a/testing/py-scipy/APKBUILD
+++ b/testing/py-scipy/APKBUILD
@@ -1,32 +1,22 @@
# Contributor: Isaac Dunham <ibid.ag@gmail.com>
# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
pkgname=py-scipy
-pkgver=0.17.0
+pkgver=0.19.0
pkgrel=0
pkgdesc="Python library for scientific computing"
url="http://www.scipy.org"
arch="all"
license="BSD"
-depends="python2 py-numpy"
+depends="python2 py-numpy-f2py"
depends_dev="python2-dev gfortran py-numpy-dev openblas-dev"
makedepends="$depends_dev py-setuptools"
install=""
subpackages="$pkgname-dev"
-source="https://files.pythonhosted.org/packages/source/s/scipy/scipy-$pkgver.tar.gz"
-
-_builddir="$srcdir"/scipy-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="https://files.pythonhosted.org/packages/source/s/scipy/scipy-$pkgver.zip"
+builddir="$srcdir"/scipy-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
export LDFLAGS="$LDFLAGS -shared"
python2 setup.py config_fc \
--fcompiler=gnu95 config || return 1
@@ -35,10 +25,8 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
-md5sums="5ff2971e1ce90e762c59d2cd84837224 scipy-0.17.0.tar.gz"
-sha256sums="f600b755fb69437d0f70361f9e560ab4d304b1b66987ed5a28bdd9dd7793e089 scipy-0.17.0.tar.gz"
-sha512sums="de6409d75a3ff3cf1e5391d3b09126f0bc7e1a40a15f9bee244195638fe2f8481fca032896d8534623e6122ff59aaf669664e27ff89cf1b094a5ce7312f220b7 scipy-0.17.0.tar.gz"
+sha512sums="3144bc14155ae790f2aba5ca6b22cbe5e7170ae1ad305774601ac22e479e1377197e47e3cd7033a5ca3464f5e944db91d3c4615111eb3369cbdd3f9079ae8c54 scipy-0.19.0.zip"