summaryrefslogtreecommitdiffstats
path: root/testing/py-serial
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-05 07:31:35 +0000
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-09-08 14:34:55 +0200
commit8048430732243be0c45ec7c20674a6ad38e41eeb (patch)
tree694bc6d7a494b3f4f426a718275641d9cb5fa394 /testing/py-serial
parent91b3053cb6541bcb31ec440fa73cc9e065dd3ec1 (diff)
testing/py-serial: var renamed
Diffstat (limited to 'testing/py-serial')
-rw-r--r--testing/py-serial/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/testing/py-serial/APKBUILD b/testing/py-serial/APKBUILD
index 756ec59a3f2..455ab46f6be 100644
--- a/testing/py-serial/APKBUILD
+++ b/testing/py-serial/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-serial
-_realname=pyserial
+_pkgname=pyserial
pkgver=2.6
pkgrel=0
pkgdesc="Python Serial Port Extension"
@@ -12,9 +12,9 @@ depends="python"
makedepends="python-dev"
install=""
subpackages="$pkgname-doc $pkgname-examples"
-source="http://pypi.python.org/packages/source/p/"$_realname"/pyserial-$pkgver.tar.gz"
-_builddir="$srcdir"/$_realname-$pkgver
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$_builddir"
python setup.py build || return 1
@@ -32,7 +32,7 @@ doc() {
_docs="appendix.rst examples.rst pyparallel.rst pyserial.rst \
pyserial_api.rst shortintro.rst"
for _doc in $_docs; do
- mv "$srcdir"/$_realname-$pkgver/documentation/$_doc \
+ mv "$srcdir"/$_pkgname-$pkgver/documentation/$_doc \
"$subpkgdir"/usr/share/doc/$pkgname/$_doc || return 1
done
}
@@ -44,9 +44,11 @@ examples() {
_examples="enhancedserial.py rfc2217_server.py scan.py \
scanlinux.py tcp_serial_redirect.py port_publisher.py port_publisher.sh"
for _example in $_examples; do
- mv "$srcdir"/$_realname-$pkgver/examples/$_example \
+ mv "$srcdir"/$_pkgname-$pkgver/examples/$_example \
"$subpkgdir"/usr/share/doc/$pkgname/examples/$_example || return 1
done
}
md5sums="cde799970b7c1ce1f7d6e9ceebe64c98 pyserial-2.6.tar.gz"
+sha256sums="049dbcda0cd475d3be903e721d60889ee2cc4ec3b62892a81ecef144196413ed pyserial-2.6.tar.gz"
+sha512sums="41682f8fafb6c5fa9642d3a0a3d6d0648101c38d157005f9c4e019e55d534953486072caf05647d8828b0e19c8259cc61cac856a570bf09904922ffd175fad2d pyserial-2.6.tar.gz"