aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-setuptools-flakes
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-06 21:37:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:16 +0000
commitacc5cf277a26e44b314fd8f7c88bca0949f32b8a (patch)
tree9f9726811e7dea135520172379dc47779af183da /testing/py-setuptools-flakes
parent704d99b56f8b5b27e4d2923af1db74230f435dd4 (diff)
testing/py-setuptools-flakes: new aport
Setuptools plugin for pyflakes https://github.com/johnnoone/setuptools-pyflakes.git
Diffstat (limited to 'testing/py-setuptools-flakes')
-rw-r--r--testing/py-setuptools-flakes/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-setuptools-flakes/APKBUILD b/testing/py-setuptools-flakes/APKBUILD
new file mode 100644
index 00000000000..d3822d7d9f9
--- /dev/null
+++ b/testing/py-setuptools-flakes/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-setuptools-flakes
+_pkgname=setuptools-flakes
+pkgver=0.1
+pkgrel=0
+pkgdesc="Setuptools plugin for pyflakes"
+url="https://github.com/johnnoone/setuptools-pyflakes.git"
+arch="noarch"
+license="BSD"
+depends="python pyflakes"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="9abc8a51ad12e47cf7c5637db0289a47 setuptools-flakes-0.1.tar.gz"
+sha256sums="a426fa68255d87c2bef00a4ef804fc01e8fa6c1982eca65e44b876d4a95dfb78 setuptools-flakes-0.1.tar.gz"
+sha512sums="e9334ebda4c92e0aff343836331241d8bd18b8211eea687e407ebdc43eaf6b48559c81afff96e6a993f083555f8b23684c08b0d9482a2d42909c6088ff639fa6 setuptools-flakes-0.1.tar.gz"