aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-sortedcontainers
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-23 14:58:58 +0000
committerAndy Postnikov <apostnikov@gmail.com>2018-04-24 00:46:58 +0300
commitf7b73dba862f6a4907827cfc8b613e738dd2a2e6 (patch)
tree7430357fc33313451ab2de516c45ce7e1b31b3ad /testing/py-sortedcontainers
parentb93c53e364560d13823fb75d20c88e7589aaf64b (diff)
testing/py-sortedcontainers: add py-nose check dependency, enable tests
Diffstat (limited to 'testing/py-sortedcontainers')
-rw-r--r--testing/py-sortedcontainers/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/testing/py-sortedcontainers/APKBUILD b/testing/py-sortedcontainers/APKBUILD
index 3761786d9fd..d014b95aa8c 100644
--- a/testing/py-sortedcontainers/APKBUILD
+++ b/testing/py-sortedcontainers/APKBUILD
@@ -9,8 +9,8 @@ url="http://www.grantjenks.com/docs/sortedcontainers/"
arch="noarch"
license="Apache"
makedepends="python2-dev py-setuptools python3-dev"
+checkdepends="py-nose"
subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
-options="!check"
source="$_pkgname-$pkgver.tar.gz::https://github.com/grantjenks/sorted_containers/archive/v$pkgver.tar.gz"
builddir="$srcdir/sorted_containers-$pkgver"
@@ -20,6 +20,12 @@ build() {
python3 setup.py build || return 1
}
+check() {
+ cd "$builddir"
+ nosetests-2.7
+ nosetests-3.6
+}
+
package() {
mkdir -p "$pkgdir"
}