aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-sphinx/APKBUILD
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2010-12-14 23:37:38 -0600
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-16 10:30:59 +0000
commit064c9f35cc947da1a133c06cfdd8094b5a2c815c (patch)
treed831d9efd06290076fce9486cb9bb3f164fe44a9 /testing/py-sphinx/APKBUILD
parentbf29f568b8e8d3c2049fde5ae86e94a281ba26b1 (diff)
testing/py-sphinx: new aport
Diffstat (limited to 'testing/py-sphinx/APKBUILD')
-rw-r--r--testing/py-sphinx/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/testing/py-sphinx/APKBUILD b/testing/py-sphinx/APKBUILD
new file mode 100644
index 00000000000..3b43e52d2bf
--- /dev/null
+++ b/testing/py-sphinx/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Matt Smith <mcs@darkregion.net>
+# Maintainer: Matt Smith <mcs@darkregion.net>
+pkgname=py-sphinx
+_pkgname=Sphinx
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="Python Documentation Generator"
+url="http://sphinx.pocoo.org/"
+arch="x86 x86_64"
+license="BSD"
+depends="python py-docutils py-jinja2 py-pygments"
+makedepends="python-dev py-setuptools"
+install=
+subpackages="$pkgname-doc"
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+doc() {
+ cd "$_builddir"
+
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname
+ for doc in AUTHORS CHANGES EXAMPLES LICENSE README TODO; do
+ install -Dm644 $doc "$subpkgdir"/usr/share/doc/$pkgname/
+ done
+
+ # Note: Documentation in the 'doc' directory (below), needs to be built
+ # with sphinx-build once sphinx is installed (see README for details).
+ #
+ # Leaving as-is; will be up to the individual user that's interested.
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname/doc/
+ cp -R ./doc/* "$subpkgdir"/usr/share/doc/$pkgname/doc/
+ chmod -R 644 "$subpkgdir"/usr/share/doc/$pkgname/doc/
+
+ # Fix subdir perms
+ find "$subpkgdir"/usr/share/doc/$pkgname/ -type d -exec chmod 755 '{}' \;
+}
+
+md5sums="9c2cbfb4f520c49cedd10d0b26196832 Sphinx-1.0.5.tar.gz"