aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-sphinxcontrib-jsoncall/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-10 09:40:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-02 09:02:52 +0000
commit909cbae3fe4f1249c1eddd3b1e7ee90e0ae6647d (patch)
tree738670c31db3ea6e728531ca14455ccfa6bd7071 /testing/py-sphinxcontrib-jsoncall/APKBUILD
parent45f914f9e6953476892af554f13e92522e0256c6 (diff)
testing/py-sphinxcontrib-jsoncall: new aport
Sphinx jsoncall extension https://pypi.python.org/pypi/sphinxcontrib-jsoncall
Diffstat (limited to 'testing/py-sphinxcontrib-jsoncall/APKBUILD')
-rw-r--r--testing/py-sphinxcontrib-jsoncall/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sphinxcontrib-jsoncall/APKBUILD b/testing/py-sphinxcontrib-jsoncall/APKBUILD
new file mode 100644
index 00000000000..0e92a2467b4
--- /dev/null
+++ b/testing/py-sphinxcontrib-jsoncall/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinxcontrib-jsoncall
+_pkgname=sphinxcontrib-jsoncall
+pkgver=0.1
+pkgrel=0
+pkgdesc="Sphinx jsoncall extension"
+url="https://pypi.python.org/pypi/sphinxcontrib-jsoncall"
+arch="noarch"
+license="MIT"
+depends="python py-sphinx"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="524a3c7803b046053d7a4a4c478f0493 sphinxcontrib-jsoncall-0.1.tar.gz"
+sha256sums="bf843ec1e57b13a823cdedb0003bb447087e9709c85c76b958534a8a185b7579 sphinxcontrib-jsoncall-0.1.tar.gz"
+sha512sums="542d223771b0318f295484b5cb46bdd4f3ff3dc527eab07f0af6ef5be2db64d143554f783712e878f38dc81d84f047e98ee2e0936e173e262d5c0806a3ae8249 sphinxcontrib-jsoncall-0.1.tar.gz"