aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-sphinxcontrib-jsx/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-08-21 16:12:48 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2014-08-23 10:28:56 +0000
commit13df6f241fc9d95518f348c33ef7ac998730d34a (patch)
treea6df54008941846db1b2fe752660e137be87abdc /testing/py-sphinxcontrib-jsx/APKBUILD
parent5b98a0cb2624c290ccc7ef04453ad46869e0a714 (diff)
testing/py-sphinxcontrib-jsx: new aport
Sphinx JSX directive extension https://pypi.python.org/pypi/sphinxcontrib-jsx
Diffstat (limited to 'testing/py-sphinxcontrib-jsx/APKBUILD')
-rw-r--r--testing/py-sphinxcontrib-jsx/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-sphinxcontrib-jsx/APKBUILD b/testing/py-sphinxcontrib-jsx/APKBUILD
new file mode 100644
index 00000000000..a94714bebb1
--- /dev/null
+++ b/testing/py-sphinxcontrib-jsx/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-sphinxcontrib-jsx
+_pkgname=sphinxcontrib-jsx
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="Sphinx JSX directive extension"
+url="https://pypi.python.org/pypi/sphinxcontrib-jsx"
+arch="noarch"
+license="BSD"
+depends="python py-sphinx"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b29d40bea29c44b435d0d76c2a61ab5a sphinxcontrib-jsx-0.2.0.tar.gz"
+sha256sums="caa24d5025785905357357d952dd75d3d728264f8361d1812f28cb9c9afc4cf6 sphinxcontrib-jsx-0.2.0.tar.gz"
+sha512sums="e7be117cc2e42978c7d7381b313b04344998ef5ddee6831325a9bd75587860dcd13aa72080880b482fef33448980af21ad0e73d0bc5feaf36a6c294a7293aaa7 sphinxcontrib-jsx-0.2.0.tar.gz"