aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-testtools
diff options
context:
space:
mode:
authorRobert Sacks <robert@sacks.email>2019-07-05 11:22:43 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-07-05 14:40:49 -0300
commitd8d1484d5aa76dc6bb5451b9970310f9a54bb768 (patch)
tree0f1d67411e83fe7dc6a3bb3524335db36bf21834 /testing/py-testtools
parent58c2764c705267e20f3d8ebe0106878051b5d691 (diff)
testing/py-testtools: use py2-traceback2 only for python2
Diffstat (limited to 'testing/py-testtools')
-rw-r--r--testing/py-testtools/APKBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/testing/py-testtools/APKBUILD b/testing/py-testtools/APKBUILD
index 130fab1216d..8e9683390c2 100644
--- a/testing/py-testtools/APKBUILD
+++ b/testing/py-testtools/APKBUILD
@@ -8,8 +8,7 @@ pkgdesc="Extensions to the Python standard library unit testing framework"
url="https://pypi.python.org/pypi/testtools"
arch="noarch"
license="MIT"
-depends="python py-pbr py-setuptools py-fixtures py-extras py-six py-traceback2
- py-mimeparse"
+depends="python py-pbr py-setuptools py-fixtures py-extras py-six py-mimeparse"
makedepends="py-setuptools py3-setuptools"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
@@ -31,7 +30,7 @@ package() {
_py2() {
replaces="$pkgname"
- depends="${depends//py-/py2-} py2-unittest2" ## remove if there are no common Python dependencies
+ depends="${depends//py-/py2-} py2-traceback2 py2-unittest2" ## remove if there are no common Python dependencies
_py python2
}