aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-timeat/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-09-12 14:03:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-29 06:48:10 +0000
commit326baada55333c9e2b9ea117ab6fff399f6903f3 (patch)
treec99bcdf54fef8750c29b41ec3320639862c1e6dd /testing/py-timeat/APKBUILD
parenteede39208f0f671d5f27b6d18ec4880041efa774 (diff)
testing/py-timeat: new aport
Show local time at given location https://bitbucket.org/tebeka/py-timeat
Diffstat (limited to 'testing/py-timeat/APKBUILD')
-rw-r--r--testing/py-timeat/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-timeat/APKBUILD b/testing/py-timeat/APKBUILD
new file mode 100644
index 00000000000..482840ecd32
--- /dev/null
+++ b/testing/py-timeat/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-timeat
+_pkgname=timeat
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="A Python module that shows local time at given location"
+url="https://bitbucket.org/tebeka/py-timeat"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="01ed6a106801f04068592025249028d4 timeat-1.0.1.tar.gz"
+sha256sums="6368f21407915b9a6b6ef5c583301c96c46faa30d40ac8ebd95138235413d365 timeat-1.0.1.tar.gz"
+sha512sums="27d749d4ebbf43aedf358be047c86e4cf7f9ff1987fdff8676ccbbc291fb7b747464d9da7f38af69e64fe062cf92c6ea2fd4cf7c0e46e57db0eb4e1854ac0a65 timeat-1.0.1.tar.gz"