aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-twisted/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-21 13:45:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-21 13:45:48 +0000
commit171b5c7d1d242eebd519815069d6359b6113a180 (patch)
treecbd4630f769572e623a5f4759f49b2fa2ec0438c /testing/py-twisted/APKBUILD
parentf9ca1925e34255433cc81edbfee99526c16bebc7 (diff)
testing/py-twisted: renamed from twisted
Diffstat (limited to 'testing/py-twisted/APKBUILD')
-rw-r--r--testing/py-twisted/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/py-twisted/APKBUILD b/testing/py-twisted/APKBUILD
new file mode 100644
index 00000000000..bc21c236f9b
--- /dev/null
+++ b/testing/py-twisted/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-twisted
+pkgver=8.2.0
+pkgrel=2
+pkgdesc="Asynchronous networking framework written in Python."
+url="http://twistedmatrix.com/"
+license="MIT"
+depends="python py-crypto py-zope-interface"
+makedepends="python-dev"
+source="http://tmrc.mit.edu/mirror/$pkgname/Twisted/8.2/Twisted-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/Twisted-$pkgver
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$srcdir"/Twisted-$pkgver
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+md5sums="c85f151999df3ecf04c49a781b4438d2 Twisted-8.2.0.tar.bz2"