aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-unicorn-hat
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-09-08 09:25:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-19 15:01:30 +0000
commitd0e82b4a6b1021929d524ab025078e9670c35833 (patch)
tree50e4e77700160c244f62c26618f96a3979380d37 /testing/py-unicorn-hat
parentf83d03c45d49e85540d0bd59556d34bf6b0600b2 (diff)
testing/py-unicorn-hat: updates version
Fixes typo in package name and updates version from 2.1.0 to 2.1.2
Diffstat (limited to 'testing/py-unicorn-hat')
-rw-r--r--testing/py-unicorn-hat/APKBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/testing/py-unicorn-hat/APKBUILD b/testing/py-unicorn-hat/APKBUILD
index 0c6fdad2690..db02c47a13e 100644
--- a/testing/py-unicorn-hat/APKBUILD
+++ b/testing/py-unicorn-hat/APKBUILD
@@ -1,12 +1,12 @@
# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
-pkgname=py-unicorni-hat
+pkgname=py-unicorn-hat
_pkgname=unicorn-hat-unicornhat
-pkgver=2.1.0
+pkgver=2.1.2
pkgrel=0
pkgdesc="Python wrapper for driving ws2812 pixels from the Raspberry Pi"
url="http://shop.pimoroni.com/products/unicorn-hat"
-arch="armhf"
+arch="armhf aarch64"
license="GPL2"
depends="python"
depends_dev=""
@@ -14,11 +14,12 @@ makedepends="python-dev py-setuptools"
install=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/pimoroni/unicorn-hat/archive/unicornhat-${pkgver}.tar.gz"
-_builddir=${srcdir}/${_pkgname}-${pkgver}
+
+builddir=${srcdir}/${_pkgname}-${pkgver}
prepare() {
local i
- cd "$_builddir"
+ cd "$builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -27,15 +28,15 @@ prepare() {
}
build() {
- cd "$_builddir/python/UnicornHat"
+ cd "$builddir/python/UnicornHat"
python setup.py build || return 1
}
package() {
- cd "$_builddir/python/UnicornHat"
+ cd "$builddir/python/UnicornHat"
python setup.py install --prefix=/usr --root="$pkgdir" || return 1
- install -D -m0644 $_builddir/LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+ install -D -m0644 $builddir/LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
}
-md5sums="e1731748d03372294edf5dedac670061 py-unicorni-hat-2.1.0.tar.gz"
-sha256sums="d9337d62b47cb0033cc95f4b90a2d5292429f756b30f34a29615db4dab6773b9 py-unicorni-hat-2.1.0.tar.gz"
-sha512sums="16a21f42a13222fa0742b2d60bcef85621519108e773840d8a73c17f3b38f38c18bd2b7038acd0b7338c69726b1a3f4da6524e37f5e7d46ce1450cd68af8e639 py-unicorni-hat-2.1.0.tar.gz"
+md5sums="63a61940a4ee469d0235454629ea60d3 py-unicorn-hat-2.1.2.tar.gz"
+sha256sums="b19430964934412b6b76dfa7b6ed7924610bda0d10e2cba47a2c580baa10da8c py-unicorn-hat-2.1.2.tar.gz"
+sha512sums="dee24ec570b8624792899fbf98fafea6565b939581ecce0adcf78c389cc0f2ec274466be31bf3e09c861a30a074f491f1366b0ac4a55529c259bfb3869d96bef py-unicorn-hat-2.1.2.tar.gz"