aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-weasyprint
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2013-08-31 20:47:14 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2013-08-31 20:47:14 +0000
commite3b7bf906c3a50087f4e3922f0e9f499c9097e22 (patch)
tree90526e022b87bfdcb7dce03ce2b86176c8c642b6 /testing/py-weasyprint
parentd2ae62d002b66d45bec5e12d89b9eec3758d7bfb (diff)
testing/py-weasyprint: new aport
Diffstat (limited to 'testing/py-weasyprint')
-rw-r--r--testing/py-weasyprint/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/py-weasyprint/APKBUILD b/testing/py-weasyprint/APKBUILD
new file mode 100644
index 00000000000..cfee5541527
--- /dev/null
+++ b/testing/py-weasyprint/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-weasyprint
+pkgver=0.19.2
+pkgrel=0
+pkgdesc="cairo-based HTML renderer for python"
+url="http://weasyprint.org"
+arch="noarch"
+license="LGPL"
+depends="python pango cairo py-cairocffi py-cairosvg py-cssselect py-tinycss py-pyphen py-lxml"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/W/WeasyPrint/WeasyPrint-$pkgver.tar.gz"
+
+_builddir="$srcdir"/WeasyPrint-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="75f1de2cf4677c53c5bff1adb23033ec WeasyPrint-0.19.2.tar.gz"
+sha256sums="63fa62b40a5bd3a1f14887950f6f40d73fff752507cd41f0040606b3d5399ba4 WeasyPrint-0.19.2.tar.gz"
+sha512sums="c491ec6788b164857265f11391148d761a737a47045288258f5584b277d58075e49384a9c0fa93ab849adbc1672684518039e2cc7bcf76b684dbab196f666166 WeasyPrint-0.19.2.tar.gz"