aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-webtest/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-28 18:04:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-30 08:23:15 +0000
commit0057e9f199c6b074ec17eaddf19d49cf2714041f (patch)
tree19abb7635ce5b0f5c18b4573076cc0083757f192 /testing/py-webtest/APKBUILD
parentbcc4a8d35065de9e9dce30c6680848637173d907 (diff)
testing/py-webtest: new aport
A Helper to test WSGI applications http://webtest.pythonpaste.org/
Diffstat (limited to 'testing/py-webtest/APKBUILD')
-rw-r--r--testing/py-webtest/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/py-webtest/APKBUILD b/testing/py-webtest/APKBUILD
new file mode 100644
index 00000000000..19cb43cfaaf
--- /dev/null
+++ b/testing/py-webtest/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-webtest
+_pkgname=WebTest
+pkgver=2.0.9
+pkgrel=0
+pkgdesc="A Helper to test WSGI applications"
+url="http://webtest.pythonpaste.org/"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools py-waitress py-six py-beautifulsoup4
+ py-webob"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="bf0a04fcf8b2cdcaa13b04324cefb53d WebTest-2.0.9.zip"
+sha256sums="749f527b39893b1757abd0e6814bde811eb25a6cf42538585c971afdb9030dad WebTest-2.0.9.zip"
+sha512sums="004848c0474a06f81849b1983d9c50ba9e142b7bfb1ce64924074b197f26cb15ac272fe5917a9c7c04b38ff2b39d191cc8d310dd2f321be878deeff710294d7a WebTest-2.0.9.zip"