summaryrefslogtreecommitdiffstats
path: root/testing/py-zeroconf
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-09 05:18:11 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-11-24 15:00:04 +0100
commitbd7bbc7d3b3f46c6ce99fba5f21dab39356bb714 (patch)
tree7a39976df27fd259c7cc521061eeafe1ed5a7056 /testing/py-zeroconf
parent989cedb9a432520711ae76f78aecd07cc60e376a (diff)
testing/py-zeroconf: new aport
A Python implementation of multicast DNS service discovery https://github.com/jstasiak/python-zeroconf
Diffstat (limited to 'testing/py-zeroconf')
-rw-r--r--testing/py-zeroconf/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/py-zeroconf/APKBUILD b/testing/py-zeroconf/APKBUILD
new file mode 100644
index 00000000000..4222a7528b2
--- /dev/null
+++ b/testing/py-zeroconf/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-zeroconf
+_pkgname=zeroconf
+pkgver=0.17.6
+pkgrel=0
+pkgdesc="A Python implementation of multicast DNS service discovery"
+url="https://github.com/jstasiak/python-zeroconf"
+arch="noarch"
+license="LGPL2+"
+depends="py-six py-enum34 py-netifaces"
+makedepends="python2-dev py-setuptools python3-dev"
+subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+md5sums="526c9e59c3d51e9e3b688922f8fc4ecd zeroconf-0.17.6.tar.gz"
+sha256sums="b614baa73833bdfc8ae64f2a9f5d19b014ad3164fbbc8513ef27a7bbe1e6c5e3 zeroconf-0.17.6.tar.gz"
+sha512sums="7385086a342d16092376ffd5ce09dab8233d0c8e9485fbfda7be4a1ae3df7cd45e407e0c8665e598555ea61c996e6a5d19e5462db40b2ecec31920e88b84191e zeroconf-0.17.6.tar.gz"