aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-zope-deprecation
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-29 06:50:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-30 08:23:15 +0000
commita66bd73bdf7da5997bfda33202d8fed4a1bb2b7e (patch)
treeb8db9bdc8b696934927a5da4d2b20fa48ff1bcf9 /testing/py-zope-deprecation
parentfc648362fce0864dd6c3de122289d0b218f5d7bc (diff)
testing/py-zope-deprecation: new aport
Zope Deprecation Infrastructure https://pypi.python.org/pypi/zope.deprecation
Diffstat (limited to 'testing/py-zope-deprecation')
-rw-r--r--testing/py-zope-deprecation/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-zope-deprecation/APKBUILD b/testing/py-zope-deprecation/APKBUILD
new file mode 100644
index 00000000000..e25410d9f2e
--- /dev/null
+++ b/testing/py-zope-deprecation/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-zope-deprecation
+_pkgname=zope.deprecation
+pkgver=4.0.2
+pkgrel=0
+pkgdesc="Zope Deprecation Infrastructure"
+url="https://pypi.python.org/pypi/zope.deprecation"
+arch="noarch"
+license="ZPL2+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="5f8cecce85f2783f9e020f1288e908fd zope.deprecation-4.0.2.tar.gz"
+sha256sums="02639fbee27bfa22f672eb18e4c173f625799459a4bc0363b86593b1d7977de6 zope.deprecation-4.0.2.tar.gz"
+sha512sums="83c1e39269836347e8d315c799c3e199d6291fcfe6dced5c46f430cb03bf98283b28ff676cea720def2984c9871811218dd72e2dba10d88cfe64ad7409b62875 zope.deprecation-4.0.2.tar.gz"