aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-zope-interface/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-21 13:15:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-21 13:16:08 +0000
commitc2e81b694405faf1a9ff12e4489d4b36a2433546 (patch)
tree420339743329700544922c9cdb5f6db841d5cdd8 /testing/py-zope-interface/APKBUILD
parent0411e8673b6610316fabfac56795927ecc02c399 (diff)
testing/py-zope-interface: renamed from zope-interface
Diffstat (limited to 'testing/py-zope-interface/APKBUILD')
-rw-r--r--testing/py-zope-interface/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/py-zope-interface/APKBUILD b/testing/py-zope-interface/APKBUILD
new file mode 100644
index 00000000000..a6c42395e0c
--- /dev/null
+++ b/testing/py-zope-interface/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-zope-interface
+pkgver=3.5.1
+pkgrel=0
+pkgdesc="Separate distribution of the zope.interface package used in Zope 3."
+url="http://www.zope.org/Products/ZopeInterface/"
+license="ZPL"
+depends="python"
+makedepends="python-dev"
+source="http://pypi.python.org/packages/source/z/zope.interface/zope.interface-$pkgver.tar.gz"
+
+_builddir="$srcdir"/zope.interface-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir"
+ rm "$pkgdir"/usr/lib/python2.6/site-packages/zope/interface/README*.txt
+}
+md5sums="685fc532550abb07cca6190c9cd2b901 zope.interface-3.5.1.tar.gz"