summaryrefslogtreecommitdiffstats
path: root/testing/py3-aiohttp-cors
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-09 06:40:45 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-11-26 12:33:34 +0100
commitf896dd4770676ecc70b68537a5950ce7ce00e732 (patch)
tree9ccf05cf41faf86d10a872f24e22a3a8cead5de9 /testing/py3-aiohttp-cors
parent75bf2672277c8c93bca7109fe06edf26dd5c0fb9 (diff)
testing/py3-aiohttp-cors: new aport
CORS support for aiohttp https://github.com/aio-libs/aiohttp-cors
Diffstat (limited to 'testing/py3-aiohttp-cors')
-rw-r--r--testing/py3-aiohttp-cors/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-aiohttp-cors/APKBUILD b/testing/py3-aiohttp-cors/APKBUILD
new file mode 100644
index 00000000000..629d20d8614
--- /dev/null
+++ b/testing/py3-aiohttp-cors/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-aiohttp-cors
+_pkgname=aiohttp_cors
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="CORS support for aiohttp"
+url="https://github.com/aio-libs/aiohttp-cors"
+arch="noarch"
+license="ASL 2.0"
+depends="py3-aiohttp"
+makedepends="python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+md5sums="f0c83969d839a5c7b9cccd7d5ea63c66 aiohttp_cors-0.4.0.tar.gz"
+sha256sums="4f4e8f7026f1c476f00498ee6f3f16110fcd65a9eb04fd02647aef3344830dca aiohttp_cors-0.4.0.tar.gz"
+sha512sums="e8e94927b1f5d0c37ea09f86dcfdff2423707174ff9892bedd0008b96c852498c6c77064bc14ab10b51a2f893ec29900e22a6bb7db5658b6f835411d6bf61b87 aiohttp_cors-0.4.0.tar.gz"