aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-astroid/APKBUILD
diff options
context:
space:
mode:
authorLuca Weiss <luca@z3ntu.xyz>2020-06-18 19:59:08 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-19 17:36:52 -0300
commit3d96b23d550c3204188dfe91396b731714e94e68 (patch)
tree32abf14e77cdc6e3191eddc6522dc819a59e376b /testing/py3-astroid/APKBUILD
parent12c3a4c7f73c5ee1685dfd57671bb13615550709 (diff)
testing/py3-astroid: remove version restrictions
As done in Arch Linux See also: * https://github.com/PyCQA/astroid/commit/e1b4e11e383bf281544f1300e41eea2ac6ab251c * https://github.com/PyCQA/astroid/issues/800 * https://github.com/PyCQA/astroid/pull/801
Diffstat (limited to 'testing/py3-astroid/APKBUILD')
-rw-r--r--testing/py3-astroid/APKBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/testing/py3-astroid/APKBUILD b/testing/py3-astroid/APKBUILD
index 2c2d9ba8fef..047e1672359 100644
--- a/testing/py3-astroid/APKBUILD
+++ b/testing/py3-astroid/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-astroid
pkgver=2.4.2
-pkgrel=0
+pkgrel=1
pkgdesc="A new abstract syntax tree from Python's ast"
url="https://www.astroid.org"
arch="noarch"
@@ -14,6 +14,15 @@ checkdepends="py3-pytest py3-pytest-runner"
source="https://files.pythonhosted.org/packages/source/a/astroid/astroid-$pkgver.tar.gz"
builddir="$srcdir"/astroid-$pkgver
+prepare() {
+ default_prepare
+ # Remove pinned version restrictions
+ sed -e 's/six~=[0-9.*]*/six/' \
+ -e 's/wrapt~=[0-9.*]*/wrapt/' \
+ -e 's/lazy_object_proxy==[0-9.*]*/lazy_object_proxy/' \
+ -i astroid/__pkginfo__.py
+}
+
build() {
python3 setup.py build
}