aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-audioread
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-24 21:05:47 +0300
committerprspkt <prspkt@protonmail.com>2019-06-24 21:28:20 +0300
commita1cf4add5e268835abda0adda8ff94569020df0c (patch)
tree6c7259946d1fb1a526c74b42c80951ca44880349 /testing/py3-audioread
parentca896ff5f3d4088cb6c5f6cdc04f7368ef34e214 (diff)
testing/py-audioread: drop python2
Diffstat (limited to 'testing/py3-audioread')
-rw-r--r--testing/py3-audioread/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-audioread/APKBUILD b/testing/py3-audioread/APKBUILD
new file mode 100644
index 00000000000..f281d139301
--- /dev/null
+++ b/testing/py3-audioread/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py3-audioread
+_pkgname=audioread
+pkgver=2.1.5
+pkgrel=2
+pkgdesc="Cross-library audio decoding for Python"
+url="https://github.com/sampsyo/audioread"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+options="!check" # upstream provides no testsuite
+source="https://files.pythonhosted.org/packages/source/a/audioread/audioread-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py-audioread" # Backwards compatibility
+provides="py-audioread=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="7589b03f9f4b11475e97ab9d114ab1bf08be8e5f9d20f3db70c9d421607f99ed66747a65d1b5e124595e520ab698e17ae9fb9a2eb453ee904ee2b6debf8b3a5c audioread-2.1.5.tar.gz"