aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-bson
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2019-07-13 13:42:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-13 15:09:09 -0300
commit3051f353aa059aaae8cb448c1df388092cb4c578 (patch)
tree85b5ca0db43eeffa2eace0be4d0385804eaf3bb3 /testing/py3-bson
parent1dc0642852332ec14161135431a71d3757a04753 (diff)
testing/py3-bson: New aport
Independent BSON codec for Python that doesn’t depend on MongoDB https://github.com/py-bson/bson
Diffstat (limited to 'testing/py3-bson')
-rw-r--r--testing/py3-bson/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-bson/APKBUILD b/testing/py3-bson/APKBUILD
new file mode 100644
index 00000000000..bc3299737f5
--- /dev/null
+++ b/testing/py3-bson/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py3-bson
+_pkgname=bson
+pkgver=0.5.8
+pkgrel=0
+pkgdesc="Independent BSON codec for Python that doesn’t depend on MongoDB"
+options="!check" # No testsuite
+url="https://github.com/py-bson/bson"
+arch="noarch"
+license="BSD-3-Clause"
+depends="py3-dateutil py3-six"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/${_pkgname/-/_}-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+ python3 setup.py test
+}
+
+sha512sums="a01762c80e9b11355b1679b3c5aad2e729b9a2e58eb061eb303c0bdae326968f4329ec0cfe1b928f288d011adf516c24600e2867cdec627777bf3648d7c1bad8 bson-0.5.8.tar.gz"