aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-cachy/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-02 04:18:43 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 16:20:35 +0000
commitd30ab6d09fe7c28352a227a2804a7b4a887057ab (patch)
tree4a7474360f70ec9de5f2f6b0bcb0d6182d1e12f8 /testing/py3-cachy/APKBUILD
parent7d919eea59b00d4106addd01b69b216af97ea952 (diff)
testing/py3-cachy: new aport
Simple yet effective caching library https://github.com/sdispater/cachy Closes GH-8381
Diffstat (limited to 'testing/py3-cachy/APKBUILD')
-rw-r--r--testing/py3-cachy/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/py3-cachy/APKBUILD b/testing/py3-cachy/APKBUILD
new file mode 100644
index 00000000000..df20ea0a337
--- /dev/null
+++ b/testing/py3-cachy/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-cachy
+_realname=cachy
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="Simple yet effective caching library"
+options="!check" # No tests on pypi tarball, github uses pyproject.toml
+url="https://github.com/sdispater/cachy"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_realname:0:1}/$_realname/$_realname-$pkgver.tar.gz"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="a6844ab93b6bba32f49ca77bee800d724a6a447aff8d3644adf05bf079298858c1a7c891460e4ab383c41082ad89368503fe7bca0b105979dd27fc348f2d070a cachy-0.2.0.tar.gz"