aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-cliff
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-07-01 14:47:32 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-07-09 08:52:35 +0000
commitfc0e8b261861fb3b9e02b170ca7f5fcad4b0fe80 (patch)
tree015e2c90a406af62633f56055a77dd61eb7fe092 /testing/py3-cliff
parenta3be5e094b2bfe57d25aeb90ad34f93e80fd3d1e (diff)
testing/py3-cliff: new aport
Diffstat (limited to 'testing/py3-cliff')
-rw-r--r--testing/py3-cliff/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-cliff/APKBUILD b/testing/py3-cliff/APKBUILD
new file mode 100644
index 00000000000..ebe7b3394fb
--- /dev/null
+++ b/testing/py3-cliff/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-cliff
+pkgver=3.3.0
+pkgrel=0
+pkgdesc="Command Line Interface Formulation Framework"
+url="https://docs.openstack.org/cliff/latest/"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-yaml"
+makedepends="py3-setuptools py3-pbr"
+checkdepends="py3-stevedore py3-prettytable"
+source="https://pypi.python.org/packages/source/c/cliff/cliff-$pkgver.tar.gz"
+options="!check" # Requires specific (old) version of py3-cmd2
+builddir="$srcdir/cliff-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="644dc14817e18dbabe8a33bd48545b27f5053f3b2c5be386c7752fe0a89d3de02aa70f6a5d7b0dcc32fb26f73773c744ba17e916c1186d93b8609caee5f08d6c cliff-3.3.0.tar.gz"