aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-daterangestr
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-12 12:08:23 +0300
committerprspkt <prspkt@protonmail.com>2019-06-15 01:21:35 +0300
commit97bdc3318652b0bc1ec4d29ac380605fd3c1447b (patch)
tree2dc14bb7f542522483d5b5b78bbb57ef1ed8dfa7 /testing/py3-daterangestr
parentc8d4d54366ce108e1a1776f88bde59365db56caa (diff)
testing/py3-daterangestr: modernize, fix provides
Diffstat (limited to 'testing/py3-daterangestr')
-rw-r--r--testing/py3-daterangestr/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/testing/py3-daterangestr/APKBUILD b/testing/py3-daterangestr/APKBUILD
index cec4d474a8a..5ef2eef7475 100644
--- a/testing/py3-daterangestr/APKBUILD
+++ b/testing/py3-daterangestr/APKBUILD
@@ -3,24 +3,23 @@
pkgname=py3-daterangestr
_pkgname=daterangestr
pkgver=0.0.3
-pkgrel=0
+pkgrel=1
pkgdesc="Utility to convert strings to start and end datetime tuples"
url="https://github.com/marians/py-daterangestr"
arch="noarch"
license="MIT"
-replaces="py-daterangestr" # for backwards compatibility
-replaces="py-daterangestr=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-daterangestr" # for backwards compatibility
+provides="py-daterangestr=$pkgver-r$pkgrel" # for backwards compatibility
+
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}